Docker compose pro `is vmnetd running?` with Docker Desktop version 4.23.0 {used localstack start for now}

This is part of the docker compose snippet

    container_name: "${LOCALSTACK_DOCKER_NAME-localstack_main}"
    image: localstack/localstack-pro:2.2.0  # required for Pro
      - ""            # LocalStack Gateway
      - ""  # external services port range
      - ""                # DNS config (required for Pro)
      - ""            # DNS config (required for Pro)
      - ""              # LocalStack HTTPS Gateway (required for Pro)

I get this error:

Attaching to localstack_main
Error response from daemon: Ports are not available: exposing port TCP -> failed to connect to /var/run/com.docker.vmnetd.sock: is vmnetd running?: dial unix /var/run/com.docker.vmnetd.sock: connect: no such file or directory

This error doe NOT allow localstack pro to start.

The issue did not happen with localstack community version.

I have confirmed this error on 2 Macs to make sure its not a port issue…

Please test with Docker Desktop version 4.23.0 (120376) on Mac OS 13.5.1.

I used localstack start for now and that worked…
so probably this is Docker Desktop issue

Hello @drrs,

Please update to the new version of Docker Desktop 4.24 and let us know if the issue is still there.
Docker Desktop release notes | Docker Docs


Well I tried that too @Marcel – did not work. Same issue.
However localstack start did work.

@drrs, can you please share the full docker-compose.yml file? Are you experiencing issues with the newer version of LocalStack 2.3 as well or with the latest version?

We do also look into our Network troubleshooting | Docs (, or DNS Server | Docs ( documentation.

If that does not help, please have a look at this docker GitHub issue Error response from daemon: is vmnetd running? · Issue #6677 · docker/for-mac (