Localstack suddenly not starting anymore

I have localstack installed using pip. All was fine, until one day it stopped launcing. Here is error

2022-11-04T11:09:30.321 DEBUG --- [  MainThread] localstack.services.infra  : [shutdown] Cleaning up resources ...
2022-11-04T11:09:30.321 DEBUG --- [  MainThread] localstack.utils.threads   : [shutdown] Done cleaning up threads / processes / tasks
2022-11-04T11:09:30.323 DEBUG --- [  MainThread] localstack.utils.run       : Executing command: rm -rf "/var/lib/localstack/tmp"
2022-11-04T11:09:30.330 DEBUG --- [  MainThread] localstack.services.infra  : [shutdown] Force shutdown, not waiting for infrastructure to shut down
Error: It appears you have a light install of localstack which only supports running in docker
If you would like to use --host, please reinstall localstack using `pip install localstack[runtime]`
2022-11-04 11:09:30,545 INFO exited: infra (exit status 1; not expected)
2022-11-04 11:09:31,557 INFO spawned: 'infra' with pid 36
^CShutting down...
2022-11-04T13:09:32.290 DEBUG --- [  MainThread] l.u.c.docker_cmd_client    : Stopping container with cmd ['docker', 'stop', '--time', '10', 'localstack_main']
2022-11-04T13:09:32.291 DEBUG --- [  MainThread] localstack.utils.run       : Executing command: ['docker', 'stop', '--time', '10', 'localstack_main']

Tried reinstalling, remove docker container, everything.
Reinstalled using pip, starting with command localstack start , but still same error.
It is MacOs.
And I have no idea what is wrong and how to fix it.

Hi :wave:

I believe that @marcel from the LocalStack team provided some fixes over the #community-support channel. I will outline them here for rest of the folks who might run into the same problem:

  • Delete your current LocalStack image and pull it again docker pull localstack/localstack:latest.
  • Try using a Python virtual environment (venv) to install LocalStack and run it.
  • Start LocalStack using Docker or Docker-Compose. Instructions on our documentation: Get Started | Docs
  • Un-install and re-install LocalStack CLI. Prefer using brew to install LocalStack since you are on MacOS.

Please let us know if you further need help with this!