EKS Cluster creation status "Failed" every time on creation

I’m using the Pro(2.3.2) version on deb11-amd64. While using the create-cluster command and waiting for few minutes the status of the cluster shows up as “FAILED”.

Based on the localstack logs I found the below error :
“Waiting for control-plane node k3d-clusterserver-server-0 startup: nodes "k3d-clusterserver-server-0" not found” (clusterserver is my cluster name)

Has anyone faced this issue before ? Can anyone please help me to resolve this issue ?
Any help in this regard is appreciated

Swarnava Pramanik


Can you share a reproducible sample to help us validate the issue? Thanks & Regards


I am facing similar issue with creating eks on localstack team edition.
I followed the below steps to start the localstack and to create the eks cluster.

Started docker with docker compose file.

After that run the command:
awslocal eks create-cluster --name cluster1 --role-arn arn:aws:iam::000000000000:role/eks-role --resources-vpc-config '{}'

My docker is behind a proxy server.

However for me eks cluster is stuck at creating status for more than 30 minutes
“cluster”: {
“name”: “cluster1”,
“arn”: “arn:aws:eks:us-east-1:000000000000:cluster/cluster1”,
“createdAt”: 1699964868.725,
“version”: “1.22”,
“roleArn”: “arn:aws:iam::000000000000:role/eksClusterRole”,
“resourcesVpcConfig”: {
“securityGroupIds”: ,
“endpointPublicAccess”: true,
“endpointPrivateAccess”: false,
“publicAccessCidrs”: [
“identity”: {
“oidc”: {
“issuer”: “https://localhost.localstack.cloud/eks-oidc
“status”: “CREATING”,
“platformVersion”: “eks.5”,
“tags”: {}

Please let me know if I am missing steps here.


Please check your Docker bridge IP. Localstack assume the Docker bridge IP the default one which is If you Docker bridge IP is different from the default one the cluster creation fails. In that case you need to provide the Docker bridge IP as the env while starting localstack like below
DOCKER_BRIDGE_IP=your docker bridge IP localstack start -d


Thanks for the suggestion. Still not working.
I am getting below error
Error creating cluster c1 - deleting and retrying: Installation of k3d failed.

I believe its a proxy issue.
it worked properly when tried creating EKS cluster in a maching without proxy.

How to ensure that the proxy is injected into the localstack so that further activities in localstack will use proxy efficiently?


Hi @Ananda,

Please have a look at our docs for Custom TLS certificates | Docs (localstack.cloud) and if you have proxy setup, you might need to experiment with the proxy variables Configuration | Docs (localstack.cloud).

1 Like